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Scope 
In this application note we explain how to use the Free-field calibration tool in ODEON in order to derive 

level-depending room acoustic parameters, such as Sound Strength (G) or STImale / STIfemale. It should be 

emphasized that all other parameters provided by ODEON do not require calibration since they depend 

only on the shape of impulse response and the relative energy decay (see more about the measuring 

system and calibration in the ODEON 13 manual[1]).   

The calibration in this application 

note was done using the small 

anechoic room at the Technical 

University of Denmark. The volume 

of the room is about 60 m
3
. 

Although the method theoretically 

requires an ideal anechoic room 

(no reflections), the 

implementation in ODEON allows 

the user to use even an ordinary 

room, but as dry as possible. The 

main process in a free field 

calibration is to derive the energy 

of the direct sound from the 

source to the receiver. ODEON 

applies an algorithm which 

excludes the reflections coming 

after the direct sound. However, 

the algorithm works better as 

these reflections become weaker.   

 

Equipment 
A very dry room is needed for the calibration. Ideally an anechoic room must be used which provides a 

reflection-free sound field. If such a room is not available, a small room full of furniture, carpets and 

curtains can be used, since ODEON is able to isolate the direct sound from the subsequent reflections 

with high success at medium and high frequencies. At low frequencies the isolation is less successful 

because sound reflections overlap, due to the large wavelengths. A good room for the free-field 

calibration should have a reverberation time of less than 0.3 sec. Apart from the room requirement, the 
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hardware needed is what it is going to be used during the normal sweep-signal measurements and it is 

the same as for the diffuse-field calibration (see application note Part 1 – Diffuse Field Method): 

1) An omni-directional loudspeaker. 
2) An omni-directional microphone. 
3) Amplifiers for the speaker (if not an active one is used) and microphone. 
4) Audio interface. 
5) Lap-top PC. 
6) ODEON 13, any edition.  
7) Ear protectors (not as necessary as for the diffuse-field calibration, since levels are much lower 

here). 
 
 

Theory 
The free field calibration is explained in the ISO standard 3382-1, for performance spaces[2]. By definition 

the sound strength 𝐺 of an omni-directional source, for a specific frequency, is given as the logarithmic 

ratio of the sound energy (squared and integrated sound pressure) of the measured impulse response to 

that of the impulse response measured in a free field at 10 m distance from the source: 

 
𝐺 = 10log10

∫ 𝑝2(𝑡)𝑑𝑡
∞

0

∫ 𝑝10
2 (𝑡)𝑑𝑡

∞

0

     dB 
(1) 

 

or 

 𝐺 = 𝐿𝑝𝐸 −  𝐿𝑝𝐸,10     dB (2) 

 

where  𝐿𝑝𝐸 = 10log10 [
1

𝑇0
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𝑝0
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0
]   and  𝐿𝑝𝐸,10 = 10log10 [

1

𝑇0
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𝑝10
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2

∞

0
]  is the sound pressure 

exposure level of 𝑝(𝑡) and 𝑝10(𝑡) respectively.  

 

The variables in these equations are as follows: 

 𝑝(𝑡): Instantaneous sound pressure of the impulse response at the receiver’s position.  
 𝑝10(𝑡): Instantaneous sound pressure of the impulse response at 10 meters distance from the source 

in free field. 
 𝑝0: Reference sound pressure, 20μPa. 
 𝑇0: 1 sec. 
 

The value of 𝐿𝑝𝐸,10 can be evaluated inside an anechoic room, where only the direct sound arrives at the 

receiver as in free field: 

 𝐿𝑝𝐸,10 = 20log10
𝑑

10
+ 𝐿𝑝𝐸

𝐴𝑛𝑒𝑐ℎ   dB = 𝐿𝑝𝐸
𝐴𝑛𝑒𝑐ℎ + 20log10(𝑑) − 20   dB (3) 
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Where 𝑑 is the distance from the source (preferably ≥ 3m) and 𝐿𝑝𝐸
𝐴𝑛𝑒𝑐ℎ is the spatial- averaged sound 

pressure exposure level at every 12.5o around the source.   

If we subtract both sides of the equation from the term 𝐿𝑝𝐸  we get:     

𝐿𝑝𝐸 − 𝐿𝑝𝐸,10 = 𝐿𝑝𝐸 − 𝐿𝑝𝐸
𝐴𝑛𝑒𝑐ℎ − 20log10 + 20   dB 

which is equivalent to 

 𝐺 = 𝐿𝑝𝐸 − 𝐿𝑝𝐸
𝐴𝑛𝑒𝑐ℎ − 20log10(𝑑) + 20   dB (4) 

 

So 𝐺 can be calculated just by knowing the relative sound pressure levels at the anechoic room 𝐿𝑝𝐸
𝐴𝑛𝑒𝑐ℎ  

and the room under measurement, 𝐿𝑝𝐸. The term relative is used to emphasise that no absolute sound 

pressure levels are needed. In other words, no calibration with a reference dB level is required, since our 

equipment cannot replace the need of a calibrated sound level meter if absolute sound pressure 

measurements are needed.  

 

Equation (3) is derived under the assumption that the power level 𝐿𝑤  of an unknown source at a specific 

frequency can be calculated from the spherical propagation law in free field measured average sound 

pressure level 𝐿𝑝𝐸
𝑅𝑒𝑣𝐶ℎ inside a reverberation chamber: 

 𝐿𝑤 = 𝐿𝑝𝐸
𝐴𝑛𝑒𝑐ℎ + 10log10(4𝜋) + 10log10(𝑑2)    dB(re 10-12 Watt) 

      = 𝐿𝑝𝐸
𝐴𝑛𝑒𝑐ℎ + 11 + 10log10(𝑑2)    dB(re 10-12 Watt) 

(5) 

   

The sound pressure level 10 meters away from this unknown source in free field conditions is calculated 

according to the spherical spread law:  

 𝐿𝑝𝐸,10 = 𝐿𝑤 − 11 − 10log10(10𝑚)2 

= 𝐿𝑤 − 31  dB 
(6) 

 

Substituting equation (5) to (6) leads to equation (3). If the sound source had a known power level of 31 

dB then the sound pressure level at 10 m would be 0 dB. By choosing the G- ISO 3382-1 spectrum in the 

measurement setup (see next section) ODEON derives the sound pressure level for a receiver as if the 

source was an omni-directional source of power level 31 dB/Octave band.  

NOTE: ODEON does not display the 𝐺 value explicitly in measured or simulated results. It displays the SPL 

(Sound Pressure Level) of a source. The value of SPL becomes equal to the value of 𝐺 only when an omni-

directional source type and a power of 31 dB/Octave band is selected in the Measurement Setup (for 

measurements) or in the Point Source Editor  (for simulations).    
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Alternatively a Speech ISO 3382-3 spectrum can be chosen in the measurement setup. In this case ODEON 

derives the sound pressure level as if the power spectrum of the source was equivalent to a human 

speaker. For derivation of STI this type of source should be chosen.   

 

Method 
We start ODEON 13 and then open the Options>Program Setup>Measurement Setup window (Figure 1).  In this 

window we should specify: 

1) The type of sweep signal to be used - the default Exponential Sweep setting is recommended for 
calibration.  
2) Audio devices – we should select the input (eg. microphone or line in) and output (speaker) devices 
used for the measurement. 
3) Receiver model – keep the default 1 channel: Omni. 
4) The source power spectrum can be specified there for used when loading the impulse response after 
measurement. For calibration of G the G- ISO 3382-1 spectrum should be chosen, while for STImale / STIfemale 
calibration the Speech ISO 3382-3 spectrum should be used. 
 

 

Figure 1: In the measurement setup important settings, like input-output devices can be performed. 
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Once all connections have been fixed we can test the measuring signal by choosing Tools>Measure IR (Sinusoidal 

Sweep) or by clicking on the  button (Figure 2). A message like: “WARNING! Calibration file not consistent 

with selected audio devices. No calibration applied” may be displayed at the bottom of the window but it 

can be ignored at this phase.  In this window the sweep length and the estimated length of the impulse 

response can be adjusted. The longer is the sweep the higher is the suppression of the background noise 

in the room. A 3 dB suppression is achieved for a doubling of the sweep length. The Play Test Signal button 

plays the sweep signal without recording any measurement. The slider in the middle of the screen adjusts 

the internal gain. Any other gain adjustments in the measuring equipment (windows mixer, audio 

interface, amplifiers) belong to external gains.  

 

 

Figure 2: Details for the sweep signal can be set in the Measure Impulse Response window. 

 

Adjusting the levels 

The most important requirement for a calibrated measurement is that all external level/gain adjustments 

must be set to fixed values during the calibration and the measurement. Only the internal gain can be 

freely changed between recordings for calibration or measurement, since ODEON itself compensates for 

the adjustment. Apparently all gains – even the internal one - should remain unchanged during a 

recording.  

It is crucial at this point to decide which should be the value of the external gains during the 

measurement in order to drive the room with an adequate signal to noise ratio without overloading. 

When overloading occurs ODEON automatically cancels the measurement. The best practice is to 

maximize the internal gain for most recordings, so that if a few of them lead to overloading, you can 

freely reduce the internal gain without harming the calibration settings.  

The most straightforward way of adjusting the external gains is to maximize all values: Windows volume 

can be set to 100% and amplifier knobs can be turned to the maximum value (Figure 3). Then all settings 
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are easy to remember/replicate during the measurement). However, one should be careful not to 

overload and damage the speaker! High output gains are also likely to cause distortion.  In addition, the 

gain of the microphone should be set to a level where the internal noise does not become very high.  

Often the amplifiers used are rather powerful for the speakers used so that a much lower gain is sufficient. 

The corresponding value must then be clearly noted down for reference. Apart from that, no extreme 

sound power output is needed if the equipment is able to derive a sufficient signal to noise ratio (SPL/Noise 

parameter inside ODEON) or decay range, in normal room conditions (with moderate ambient noise). 

 

 

Recording 

After fixing the external level adjustments, recordings of impulse responses in the anechoic/dry room can 

be performed by clicking the Measure button in the Measure Impulse Response window. An introductory video on 

how to obtain measurements in room can be found at [4]. The recordings are saved as .WAV files. Some 

trial measurements should be performed initially by varying the internal gain until an adequate signal to 

noise ratio is achieved. It can be desirable to make the measurement with the highest possible SNR, 

achievable without overload, but this is not required. NOTE: Use ear protectors to prevent hearing 

damage! An indication of the quality of the signal to noise ratio can be obtained by loading the recording 

on the Load impulse response tool,  (under the Tools menu) and checking whether all SPL values at octave 

Figure 3: Levels and gains in the windows mixer are considered external adjustments and should remain 
fixed during calibration and measurements. A straightforward recommendation is to set all parameters 
at their maximum value. 
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bands have been derived. A “*” character means that ODEON was unable to derive the corresponding 

value from the impulse response (eg. due to insufficient signal to noise ratio/ decay range). In contrast to 

a diffuse-field calibration, “*” characters are expected here for most parameters, except SPL, because any 

impulse response is truncated at the direct sound –too short length to provide sufficient information for 

most of the parameters. An example of a successful impulse response in the anechoic/dry room is given in 

Figure 4, where all SPL values have been derived. The sound strength parameter (𝐺 value) is denoted as 

SPL (dB) and is not calibrated yet. Hence it is expected that SPL can be very awkward (even negative, 

meaning much lower sound pressure than the reference 20 μPa).  

Source – Receiver positions in the anechoic/dry room 

The source should be placed at a stable location almost at the center of the room and far away from walls 

and furniture (if any). The microphone should be placed ideally at positions every 12,5o around the source, 

preferably at a radius greater than 3m[2]. This gives roughly 28 spots. However to our experience even half 

spots (14) can be a good compromise between accuracy and speed. The distance of the microphone from 

the source should be as precise as possible, because the measured sound pressure level can vary 

significantly with slight changes (figure 5). A good tip is to use a piece of rope with nooses at the end, tied 

at the source and microphones stands. Stretching the piece of rope every time you move the microphone 

around the source will ensure a fixed distance from it. Figure 6 shows illustrates the geometry for a free-

field calibration. 

 

Figure 4: Room acoustic parameters from a healthy impulse response recording inside the anechoic/dry 
room. Since only the direct sound is taken into account, it should not be expected to obtain all acoustic 
parameters. The only relevant parameter is SPL.   
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Figure 5: Diagram of measurement positions for free-field calibration. The source should be fixed 
roughly at the center of the room and the microphone should be placed at a fixed radius around the 
source. Ideally 28 positions are required (red spots) but 14 is also an acceptable number.  

 

Deriving the Calibration File 

Having a series of impulse responses in the room we can derive the calibration file to be used with the 

actual measurement by clicking on Tools>Measurement Calibration>Free-field>One step (requires fixed signal chain). Two 

stages are required now: 

1st Stage 

ODEON asks for the geometry of the source-receiver 

configuration, in order to estimate the arrival time of 

the first reflection after the direct sound and truncate 

the impulse response just before this reflection.  

If calibration is done in an ordinary dry room the 
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precise heights and distances should be entered in the boxes. Figure 6 shows a typical geometry, where 

the floor is the closest surface and creates the 1st reflection. All heights and distances should be measured 

from the centres.  

However, when the recordings are performed in a purely anechoic room there is no need for truncating 

the impulse response as there are virtually no reflections. In this case it is advisable to set a high value for 

the heights (around 10 m) in order to ensure that the whole energy associated with the direct sound is 

included. Besides, an anechoic room usually has a phantom floor: Source, microphone, people and 

equipment stand on a metal grid far above the absorptive wedges in the bottom of the anechoic chamber. 

So practically there is no floor to create reflections.   

 

 

 

Figure 6: Geometry for impulse response recording in the anechoic/dry room. It is advisable to use a 
piece of stretched rope with loops to ensure constant distance between source-receiver (preferably 
<3m). ODEON needs to know the time difference between the arrival of the 1st reflection and the direct 
sound (t2-t1). This is calculated by entering the source and receiver heights, as well as the source-
receiver distance.  

 

2nd stage 

All recordings (.WAV files) measured at the receiver positions according to figure 5 should be selected 

together using the SHIFT or CTRL key and opened at once. ODEON then derives the free field calibration 
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values (adjustments) for the eight octave bands between 63 Hz and 8000 Hz as an average of the different 

positions (Figure 5) and asks for a name of the calibration file. The user is prompted to set the file as the 

active calibration file in the Measurement Setup, which is going to be used with future measurements. It is also 

possible to change the active calibration file afterwards in the Measurement Setup in the Calibration File menu.  

However, if the input and output devices are different from those used during the generation of the 

calibration file ODEON gives a warning for device mismatch, meaning that all level depended parameters 

will not be calibrated in future measurements. You can now launch the Measurement Setup window to check 

whether the active calibration file is the correct one.     

 

Figure 7: Fourteen impulse responses and calibration values derived by ODEON. For each impulse 
response the SPL values recorded in ODEON are reported. At the bottom of the table the average SPL is 
shown and the free field calibration values are derived.  

 

Calibrated Measurements 

Actual measurements can be carried out with the Measure IR (Sinusoidal Sweep) tool using the active calibration 

file in the Measurement Setup. Calibration will be applied on the recorded .WAV files during processing at the 

Load impulse response tool,  (under the Tools menu). If there is a mismatch between the input/output devices 

used for the calibration file and the ones used for the measurement, a warning is displayed by ODEON 

and no calibration is applied.  

In the ODEON measuring system the chain of calibration and measurement can be reversed: Someone 

could measure first and calibrate the equipment afterwards as long as the external gains are fixed. When 
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the measurement is finished a calibration file can by assigned by clicking Tools>Measurement Calibration>Assign 

Calibration to Existing Measurements.     

An example of calibrated measurement is shown in figure 8. The calibration file from figure 7 was used in 

this case. The SPL values correspond to the sound strength of the source, since a G-ISO 3382-1 source 

power spectrum has been chosen in the Measurement Setup, as shown in figure 1.  

 

Figure 8: SPL measurement calibrated with the calibration file derived in figure 7. These SPL values 
correspond to the sound strength G of the source, since a G-ISO 3382-1 sound power spectrum has 
been chosen in the Measurement Setup (see figure 1). 

Conclusion 
The note describes the steps required for a calibrated measurement of G and STI using an anechoic (free-

field) room. Another way for calibration is utilizing a reverberation chamber – performing a so called 

diffuse field calibration. The sound field for both environments is considered to be fully known, as long as 

specific assumptions hold (free field respectively and diffuse field). For this reason the sound power of an 

unknown source can be specified from analytic expressions like eq.(5) and calibration of the equipment 

towards a known source like G-ISO 3382-1 and Speech-ISO 3382-3 can be done. 

The basic steps described in this note hold for a diffuse-field calibration as well and the main difference is 

the way the power of the unknown source is derived. For that matter, one could follow the same process 

for such a calibration just by selecting Tools>Calibrate Measurements>Diffuse field>One step (requires fixed signal chain).  
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