ODEON APPLICATION NOTE
Calibration of Impulse Response Measurements

Part 1 – Diffuse Field Method

GK, CLC - November 2013

Scope
In this application note we explain how to use the Diffuse-field calibration tool in ODEON in order to derive level-depending room acoustic parameters, such as Sound Strength (G) or STI. It should be emphasized that all other parameters provided by ODEON do not require calibration since they depend only on the shape of impulse response and the relative energy decay (see more about the measuring system and calibration in the ODEON 13 manual[1]).

The calibration in this application note was done using the Large Reverberation Chamber at the Technical University of Denmark. The volume of the chamber is 245 m$^3$ and provides a reverberation time of about 8 sec at low frequencies. Reflective panels are placed near the walls at various angles in order to distribute reflections evenly and enhance the diffusivity of the sound field. Even when another type of room is used for the calibration, a diffuse sound field should be achieved, utilizing some scattering surfaces or objects. A perfect, rectangular room with hard walls would lead to flutter echoes (visible at the impulse response) that would violate the assumptions of linear decay, taken for the diffuse-field calibration.

Equipment
A highly reverberant and diffuse field room is needed for the calibration. The ideal type of room is a reverberation chamber. If such is not available, a room with hard walls could be acceptable (eg. a big bathroom). However the chosen room should be as diffuse as possible meaning that highly symmetric shapes (eg. rectangular) must be avoided and some extra treatment might be required: placing of hard, scattering objects around the walls or the floor. It is a good practice to check always for the degree of linearity of the decay curve in each octave band through one of the $XI$ parameters. If $XI$ exceeds 10 $\circ / \circ$ this is an indication that the decay is strongly non-linear, because of flutter echo or due to impulsive noise during the measurement. You can read more about the $XI$ parameter in the ODEON help file, which can be
easily accessed by pressing F1 while working with the measuring system. Apart from this requirement, the hardware needed for calibration is exactly the same as for the sweep-signal measurement:

1) An omni-directional loudspeaker.
2) An omni-directional microphone.
3) Amplifiers for the speaker (if not an active one is used) and microphone.
4) Audio interface.
5) Lap-top PC.
6) ODEON 12, any edition.
7) Ear protectors.

Theory
The diffuse field calibration is explained in the ISO standard 3382-1, for performance spaces[3]. By definition the sound strength $G$ of an omni-directional source, for a specific frequency, is given as the logarithmic ratio of the sound energy (squared and integrated sound pressure) of the measured impulse response to that of the impulse response measured in a free field at 10 m distance from the source:

$$G = 10 \log_{10} \frac{\int_{t_0}^{\infty} p^2(t) dt}{\int_{t_0}^{\infty} p_{10}^2(t) dt} \text{ dB} \quad (1)$$

or

$$G = L_{pE} - L_{pE,10} \text{ dB} \quad (2)$$

where $L_{pE} = 10 \log_{10} \left[ \frac{1}{T_0} \int_{t_0}^{\infty} \frac{p^2(t) dt}{p_0^2} \right]$ and $L_{pE,10} = 10 \log_{10} \left[ \frac{1}{T_0} \int_{t_0}^{\infty} \frac{p_{10}^2(t) dt}{p_0^2} \right]$ is the sound pressure exposure level of $p(t)$ and $p_{10}(t)$ respectively.

The variables in these equations are as follows:

- $p(t)$: Instantaneous sound pressure of the impulse response at the receiver’s position.
- $p_{10}(t)$: Instantaneous sound pressure of the impulse response at 10 meters distance from the source in free field.
- $p_0$: Reference sound pressure, 20μPa.
- $T_0$: 1 sec.

The value of $L_{pE,10}$ can be evaluated inside a reverberation chamber, using the diffuse field approximation:

$$L_{pE,10} = 10 \log_{10} \frac{A}{S_0} - 37 + L_{pE}^{RevCh} \text{ dB} \quad (3)$$
Where $A$ is the equivalent absorption area in the room that is calculated from the Sabine’s formula (diffuse field assumption): $A = 0.16V/T$, with $V$ being the volume (m$^3$) and $T$ the reverberation time (sec). In addition, $S_0 = 1$ m$^2$.

$L_{pE}^{RevCh}$ is the spatial-averaged sound pressure exposure level as measured in the reverberation chamber.

If we subtract both sides of the equation from the term $L_{pE}$ we get:

$$L_{pE} - L_{pE, 10} = -10\log_{10} \frac{A}{S_0} + 37 + L_{pE} - L_{pE}^{RevCh} \quad \text{dB}$$

which is equivalent to

$$G = 37 - 10\log_{10} \frac{A}{S_0} + L_{pE} - L_{pE}^{RevCh} \quad \text{dB} \quad (4)$$

So $G$ can be calculated just by knowing the relative sound pressure levels at the reverberation chamber $L_{pE}^{RevCh}$ and the room under measurement, $L_{pE}$. The term relative is used to emphasise that no absolute sound pressure levels are needed. In other words, no calibration with a reference dB level is required, since our equipment cannot replace the need of a calibrated sound level meter if absolute sound pressure measurements are needed.

Equation (3) is derived under the assumption that the power level $L_w$ of an unknown source at a specific frequency can be calculated from the measured average sound pressure level $L_{pE}^{RevCh}$ inside a reverberation chamber:

$$L_w = L_{pE}^{RevCh} - 6 + 10\log_{10} \frac{A}{S_0} \quad \text{dB}(\text{re } 10^{-12} \text{ Watt}) \quad (5)$$

The sound pressure level 10 meters away from this unknown source in free field conditions is calculated according to the spherical spread law:

$$L_{pE, 10} = L_w - 11 - 10\log_{10} (10m)^2 = L_w - 31 \quad \text{dB} \quad (6)$$

Substituting equation (5) to (6) leads to equation (3). If the sound source had a known power level of 31 dB then the sound pressure level at 10 m would be 0 dB. By choosing the G-ISO 3382-1 spectrum in the measurement setup (see next section) ODEON derives the sound pressure level for a receiver as if the source was an omni-directional source of power level 31 dB/Octave band.

**NOTE:** ODEON does not display the $G$ value explicitly in measured or simulated results. It displays the SPL (Sound Pressure Level) of a source. The value of SPL becomes equal to the value of $G$ only when an omni-directional source type and a power of 31 dB/Octave band is selected in the Measurement Setup (for measurements) or in the Point Source Editor (for simulations).
Alternatively a Speech ISO 3382-3 spectrum can be chosen in the measurement setup. In this case ODEON derives the sound pressure level as if the power spectrum of the source was equivalent to a human speaker. For derivation of STI this type of source should be chosen.

**Method**

Inside the reverberant room we specify a group of source-receiver positions. A good number is 2 source and 3 receiver positions, giving 6 combinations\(^3\). We start ODEON 12 and then open the *Options*>Program Setup>Measurement Setup* window (Figure 1). In this window we should specify:

1) The type of sweep signal to be used - the default *Exponential Sweep* setting is recommended for calibration.
2) Audio devices – we should select the input (eg. microphone or line in) and output (speaker) devices used for the measurement.
3) Receiver model – keep the default 1 channel: Omni.
4) The source power spectrum can be specified there for used when loading the impulse response after measurement. For calibration of G the G-ISO 3382-1 spectrum should be chosen, while for STI calibration the Speech ISO 3382-3 spectrum should be used.

Once all connections have been fixed we can test the measuring signal by choosing *Tools*>Measure IR (Sinusoidal Sweep) or by clicking on the \(\text{△}\) button (Figure 2). A message like: “**WARNING! Calibration file not consistent with selected audio devices. No calibration applied**” may be displayed at the bottom of the window but it can be ignored at this phase. In this window the sweep length and the estimated length of the impulse response can be adjusted. The longer is the sweep the higher is the suppression of the background noise in the room. A 3 dB suppression is achieved for a doubling of the sweep length. The *Play Test Signal* button plays the sweep signal without recording any measurement. The slider in the middle of the screen adjusts the internal gain. Any other gain adjustments in the measuring equipment (windows mixer, audio interface, amplifiers) belong to external gains.
Figure 1: In the measurement setup important settings, like input-output devices can be performed.

Adjusting the levels
The most important requirement for a calibrated measurement is that all external level/gain adjustments must be set to fixed values during the calibration and the measurement. Only the internal gain can be freely changed during the measurement, since ODEON itself compensates for the adjustment. So it is crucial at this point to decide which should be the value of the external gains during the measurement in order to drive the room with an adequate signal to noise ratio without overloading. When overloading occurs ODEON automatically cancels the measurement.
Figure 2: Details for the sweep signal can be set in the Measure Impulse Response window.

Figure 3: Levels and gains in the windows mixer are considered external adjustments and should remain fixed during calibration and measurements. A straightforward recommendation is to set all parameters at their maximum value.
The most straightforward way for adjusting the external gains is to maximize all values: Windows volume can be set to 100% and amplifier knobs can be turned to the maximum value (Figure 3). Then all settings are easy to remember/replicate during the measurement. However, one should be careful not to overload and damage the speaker! In addition the gain of the microphone should be set to a level where the internal noise does not become very high.

Often the amplifiers used are rather powerful for the speakers used so that a much lower gain is sufficient. The corresponding value must then be clearly noted down for reference. Apart from that, no extreme sound power output is needed if the equipment is able to derive a sufficient signal to noise ratio (SPL/Noise parameter inside ODEON) or decay range, in normal room conditions (with moderate ambient noise).

The internal gain can be changed during the measurement but it should remain stable during the calibration at a value of convenience. Again a straightforward choice is to place it at the maximum possible value before leading to overloading or clipping. Then the value can be reduced in the room under measurement as long as the signal to noise ratio is adequate.

Recording
After fixing the external level adjustments, recordings of impulse responses in the reverberant room can be performed by clicking the Measure button in the Measure Impulse Response window. An introductory video on how to obtain measurements in room can be found at [4]. The recordings are saved as .WAV files. Some trial measurements should be performed initially by varying the internal gain until an adequate signal to noise ratio is achieved. It can be desirable to make the measurement with the highest possible SNR, achievable without overload, but this is not required. **NOTE:** Use ear protectors to prevent hearing damage! An indication of the quality of the signal to noise ratio can be obtained by loading the recording on the Load impulse response tool, 📊 (under the Tools menu) and checking whether there are any “*” characters on the calculated room acoustic parameters. A “*” character means that ODEON was unable to derive the corresponding value from the impulse response (eg. due to insufficient signal to noise ratio/ decay range). An example of a successful impulse response in the reverberation chamber is given in Figure 4, where all parameters have been derived. The sound strength parameter ($G$ value) is denoted as SPL (dB) and is not calibrated yet.

Deriving the Calibration File
Having a series of impulse responses in the room we can derive the calibration file to be used with the actual measurement by clicking on Tools>Calibrate Measurements>Diffuse field>One step (requires fixed signal chain). ODEON asks for the volume of the reverberant room and then for the impulse responses. The files should be selected all together using the SHIFT or CTRL key and opened at once. ODEON then derives the calibration values for the eight octave bands between 63 Hz and 8000 Hz as an average from the different positions (Figure 5) and asks for a name of the calibration file. The user is prompted to set the file as the active calibration file in the Measurement Setup, which is going to be used with the measurements. It is possible to change the calibration file used in the Measurement Setup in the Calibration File menu. However, if the input and output devices are different from those used during the generation of the calibration file ODEON gives a
warning for device mismatch, meaning that all level depended parameters will not be calibrated. You can now launch the Measurement Setup window to check whether the active calibration file is the correct one.

Figure 4: Room acoustic parameters from a healthy impulse response recording inside the reverberation chamber. A sufficient decay range for each octave band makes sure that all parameters are derived.

Calibrated Measurements

Measurements can be carried out with the Measure IR (Sinusoidal Sweep) tool or an external stimulus using the active calibration file in the Measurement Setup. Calibration will be applied on the recorded .WAV files during processing at the Load impulse response tool, (under the Tools menu). If there is a mismatch between the input/output devices used for the calibration file and the ones used for the measurement, a warning is displayed by ODEON and no calibration is applied.

In the ODEON measuring system the chain of calibration and measurement can be reversed: Someone could measure first and calibrate the equipment afterwards as long as the external gains are fixed. When the measurement is finished a calibration file can by assigned by clicking Tools>Measurement calibration>Assign Calibration to Existing Measurements.

An example of calibrated measurement is shown in figure 6. The calibration file from figure 5 was used in this case. The SPL values correspond to the sound strength of the source since, a G-ISO 3382-1 source power spectrum has been chosen in the Measurement Setup, as shown in figure 1.
Figure 5: Six impulse responses and calibration values derived by ODEON.

Figure 6: SPL measurement calibrated with the calibration file derived in figure 5. These SPL values correspond to the sound strength $G$ of the source, since a $G$-ISO 3382-1 sound power spectrum has been chosen in the Measurement Setup (see figure 1).
Conclusion

The note describes the steps required for a calibrated measurement of G and STI using a reverberation (diffuse) room. Another way for calibration is utilizing an anechoic chamber – performing a so called free field calibration. The sound field for both environments is considered to be fully known, as long as specific assumptions hold (diffuse field and free field respectively). For this reason the sound power of an unknown source can be specified from analytic expressions like eq.(5) and calibration of the equipment towards a known source like G-ISO 3382-1 and Speech-ISO 3382-3 can be done.

The basic steps described in this note hold for a free-field calibration as well and the main difference is the way the power of the unknown source is derived. For that matter, one could follow the same process for such a calibration just by selecting Tools>Calibrate Measurements>Free field>One step (requires fixed signal chain).

References